Firefox : Rendre compatible des anciens modules complémentaires

0
85

Si comme moi vous êtes fan des plugins pour Firefox vous avez déjà surement rencontré des versions obsolètes qui vous intéressaient que vous ne pouviez pas installer. Il est possible de les rendre compatible mais je vous préviens tout de suite il est possible que cela entraîne des bugs. Ceci-dit la plupart du temps ça fonctionne plutôt bien.

Le système d’installation de modules complémentaires utilise des fichiers .xpi que vous allez pouvoir télécharger sur le portail de Mozilla grâce à Internet Explorer, Google Chrome ou encore Safari. En effet, ces navigateurs ne comprennent pas ce format et vous pourrez donc les rapatrier sur votre disque dur.

Décompressez le .xpi comme n’importe quelle archive zip. En fait, les .xpi sont ni plus ni moins que des fichiers zippés, à l’intérieur vous y trouverez install.rdf qui contient les données de compatibilité. Trouvez la ligne <em:maxVersion>1.0</em:maxVersion>, cette balise donne la version maximale de Firefox où le plugin peut être installé, changez là et mettez votre numéro de version de votre navigateur (ou un numéro supérieur).

Rezippé le tout et renommez le fichier en .xpi, vous n’avez plus qu’à l’ouvrir avec Firefox et l’installation fonctionnera. Encore une fois attention car il est possible que certains plugins complexes puissent faire planter votre navigateur mais pour ma part je n’ai jamais eu de problèmes sauf avec certains thèmes qui ne s’affichaient pas correctement.

Nous avons besoin de vous !

Tu as aimé cet article ? Tu peux nous soutenir en achetant l'un de nos t-shirts, faire un tour sur notre sexshop. Si tu n'as pas de thunes, tu peux aussi nous aider en partageant cet article sur les réseaux sociaux.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here